0
-
0

excel demande d'aide

* Francoise
Anonyme
Envoyé le 16/02/2012 à 10:22

Bonjour,

j'ai 2 colonnes avec une la date et l'autre un code opération
je désire les compter en mettant que si le code 120 par exemple se retrouve dans un plage précise et que ce dernier est également dans le mois de fevrier alors on compte en faisant la formule suivante : =sommeprod(h6:h16=120*(i6:i16="fevrier") cela me resort systematiquement à 0 alors que je devrais avoir 2
pouvez vous m'aider
Bonne journée



Claude40 Claude40
1 138 contributions
Membre depuis le 24/03/2010
Envoyé le 16/02/2012 à 12:04 Modifié par Claude40


Bonjour,
Il semble que la fonction ne soit pas la bonne par rapport à ton problème.
En outre, il semble manquer un argument.
Peux-tu donner la liste complète des cellules des plages concernées avec les valeurs inscrites et les valeurs que tu attends en résultat ?
Avec SOMMEPROD, on ne compte pas. On additionne le contenu des cellules qui correspondent aux critères de recherche.
Dans ton exemple, avec une fonction qui marche, on obtiendrait le résultat 120
si une seule cellule en H contient 120 en face d'une autre cellule contenant février en I. Si, dans la plage H6:H16 on a plusieurs fois 120 et plusieurs fois fevrier en face on obtiendra en résultat un multiple de 120.

Si tu veux afficher combien de fois 120 et fevrier sont ensemble, il faut coder : =NB.SI.ENS(H6:H16;120;I6:I16;"fevrier")
A +
L'expérience de chacun est le trésor de tous (Gérard de Nerval). Un bon exposé du problème, c'est déjà un grand pas vers la solution.
Mytå_Qc Mytå_Qc
30 contributions
Membre depuis le 06/08/2010
Envoyé le 16/02/2012 à 23:43 Modifié par Mytå_Qc


Bonjour,

La formule sous Excel 2003


=SOMMEPROD((H6:H16=120)*(I6:I16="fevrier"))


La formule sous Excel 2007 et +


=NB.SI.ENS(H6:H16;120;I6:I16;"fevrier")


Les deux formules sont des équivalences.

Mytå_Qc



Claude40 Claude40
1 138 contributions
Membre depuis le 24/03/2010
Envoyé le 17/02/2012 à 09:33


Bonjour,

Exact, je ne connaissais pas cette façon "détournée", mais astucieuse d'utiliser SOMMEPROD (qui fonctionne aussi sous Excel 2007).
La définition officielle de la fonction SOMMEPROD est : "Multiplie les valeurs correspondantes des matrices spécifiées et calcule la somme de ces produits."
Mais tous ces "efforts" d'explications sont-ils bien justifiés pour quelqu'un qui poste et ne revient pas consulter les réponses ?
L'expérience de chacun est le trésor de tous (Gérard de Nerval). Un bon exposé du problème, c'est déjà un grand pas vers la solution.
Mytå_Qc Mytå_Qc
30 contributions
Membre depuis le 06/08/2010
Envoyé le 18/02/2012 à 19:55


Bonjour,

Des explications supplémentaires sur SOMMEPROD

Mytå_Qc



Discussion trop ancienne

Cette discussion a été automatiquement fermée car elle n'a plus reçue de nouveau message depuis trop longtemps.

Nous vous suggérons de créer un nouveau message

« Retour sur la liste des messages de ce forum