L’index automatique et les ponctuations ʼ :

jawa123
27 contributions
Membre depuis le 04/05/2017
Envoyé le 18/05/2017 à 10:01


Bonjour,
J’ai créé sur un document de +600 pages, un Index des Noms, avec un fichier de concordance à 2 colonnes de Noms et Prénoms.
La colonne de gauche figure les Noms, et celle de droite les Noms et Prénoms.

Tout va bien jusque-là, sauf que pour les Noms qui possèdent une apostrophe, l’index ne le reconnait pas et ne figure pas dans la liste.

Exemple : dʼOccam Guillaume ; DʼOrs Eugenio, D'Estaing Giscard , etc.

Y a-t-il une explication à cela ?

Je dois aussi créer un Index de références. J'ai d'abord fait un fichier à 1 colonne et ensuite un fichier de concordance à 2 colonnes, en mettant à gauche et à droite les mêmes références.

Exemple :

Genèse 1 : 1
Genèse 1 : 31
Genèse 2 et 3
Genèse 3 : 4-5

L’index ne reconnait pas la ponctuation :

Et voici le résultat :

Genèse 1
1, 1
31, 1
Genèse 2 et 3, 2
Genèse 22
18, 4
Genèse 3
14, 3
15, 3
4-5, 2
5, 2

Avec mes remerciements pour votre aide.



Répondre à ce message

Bipbipcoyote Bipbipcoyote
1 761 contributions
Membre depuis le 06/03/2001
Envoyé le 19/05/2017 à 13:25 Modifié par Bipbipcoyote


Bonjour,
je n'ai jamais exécuté ce genre de choses, mais comme c'est une question vraiment spécifique, j'ai trouvé [url=https://support.office.com/fr-fr/article/Cr%C3%A9er-un-index-bff6fead-11a0-4848-891b-44a9cbc975a1]l'aide de m$ pour word concernant la création d'un index[/url]

Le lien ne s'inscrit pas correctement dans le message, fais alors un copier-coller de ceci dans ton navigateur

https://support.office.com/fr-fr/article/Cr%C3%A9er-un-index-bff6fead-11a0-4848-891b-44a9cbc975a1

Je vois qu'il faut choisir la langue, c'est une première piste.
En second, comme il s'agit d'un outil de recherche à travers un texte, tu peux contourner ton problème d'apostrophe en utilisant simplement Occam Guillaume,Ors Eugenio et Estaing Giscard, cela t'amènera sur les mêmes endroits.
Pour le 2ème souci, je pense qu'il faut entrer des sous-entrées comme expliqué au point 4 sur le lien ci-dessus
Google est mon ami, il répond mieux que moi, posez lui d'abord vos questions Visitez mon Site
Claude40 Claude40
1 121 contributions
Membre depuis le 24/03/2010
Envoyé le 19/05/2017 à 14:49


Bonjour Bibipcoyote et jawa123
Pour le lien, il manquait le crochet fermé après "[url".
Pour l’apostrophe, c’est un grand classique car ce caractère est utilisé comme séparateur par toutes les applications. Les deux possibilités de contournement sont la solution de Bibipcoyote valable, malheureusement, uniquement si l’apostrophe est en deuxième position du champ et une macro pas évidente d’ailleurs.
Pour le deuxième aspect, je pense que la piste des sous-entrées est la bonne, bien que n’ayant jamais pratiqué moi-même non plus. Les index sont effectivement des fonctionnalités délicates de Word et relativement peu utilisées.


Un bon exposé du problème, c'est déjà un grand pas vers la solution. Dans la mesure du possible, mes solutions sont testées, sur mon système actuel (W10 Pro), mais peuvent ne pas fonctionner sur tous les Pc
jawa123
27 contributions
Membre depuis le 04/05/2017
Envoyé le 19/05/2017 à 15:43


Bonjour,
OK pour la première réponse.

La seconde avec les sous-entrées donne le même résultat.

Il faudrait peut-être créer une macro, car j'ai essayé dans tous les sens.

Bipbipcoyote Bipbipcoyote
1 761 contributions
Membre depuis le 06/03/2001
Envoyé le 20/05/2017 à 02:18 Modifié par Bipbipcoyote


Bonjour,
Et les hyperliens, ne serait-ce pas une solution ?[url=https://support.office.com/fr-fr/article/Cr%C3%A9er-modifier-ou-supprimer-un-lien-hypertexte-68968ad1-a64d-4149-b814-59050e3a9c60]Point N°4 créer un lien dans le document[/url]

Ce n'est pas automatique, mais certainement plus sûr

NB: il faut que l'équipe de mémoclic se penche sur la validité des liens :D (il doit y avoir des caractères qui ne sont pas acceptés dans le script

Google est mon ami, il répond mieux que moi, posez lui d'abord vos questions Visitez mon Site
Claude40 Claude40
1 121 contributions
Membre depuis le 24/03/2010
Envoyé le 20/05/2017 à 10:19 Modifié par Claude40


Bonjour,
Le lien fonctionne en ajoutant le crochet fermé et en supprimant le signe =.
support.office.com/fr-fr/article/Cr%C3%A9er-modifier-ou-supprimer-un-lien-hypertexte-68968ad1-a64d-4149-b814-59050e3a9c60]Point N°4 créer un lien dans le document


Un bon exposé du problème, c'est déjà un grand pas vers la solution. Dans la mesure du possible, mes solutions sont testées, sur mon système actuel (W10 Pro), mais peuvent ne pas fonctionner sur tous les Pc
Bipbipcoyote Bipbipcoyote
1 761 contributions
Membre depuis le 06/03/2001
Envoyé le 21/05/2017 à 15:14


Bonjour,
Le crochet fermé y était et le signe = est ajouté par l'interface quand on crée le lien... pas ma faute [:D]
Google est mon ami, il répond mieux que moi, posez lui d'abord vos questions Visitez mon Site
Claude40 Claude40
1 121 contributions
Membre depuis le 24/03/2010
Envoyé le 22/05/2017 à 09:00 Modifié par Claude40


Bonjour,
La réaction ne semble pas la même pour toutes les machines.
Chez moi, le crochet est maintenu ainsi que le signe = et le lien fonctionne apparemment !
Mais, on s'égare et on est en train de "polluer" un sujet qui n'est pas celui-là !

http://www.memoclic.com/forum/131623-lindex-automatique-et-les-ponctuations#body_1113729

Un bon exposé du problème, c'est déjà un grand pas vers la solution. Dans la mesure du possible, mes solutions sont testées, sur mon système actuel (W10 Pro), mais peuvent ne pas fonctionner sur tous les Pc

Participer à cette discussion

« Retour sur la liste des messages de ce forum