Excel, compter le nombre de Oui

spectroms spectroms
103 contributions
Membre depuis le 13/04/2001
Envoyé le 09/04/2009 à 08:56


Bonjour,

J\'ai 4 feuilles excel.
Sur les 3 premières j\'ai une colonne (toujours la même) avec des \"Oui\", \"Non\" ou \"NC\".
Sur la dernière feuille, j\'aimerais avoir le nombre total de \"Oui\", de \"Non\" et de \"NC\".
Comment faire ?

Merci d avance
˜šššš˜'°º^v^^v^-= SpectromS =-^v^^v^º°'˜šššš˜
Auvergnat de Paris

compte désactivé

Bonjour

Ca serrait pas la fonction \"filtrer\" ca si mes souvenirs sont bons.

J\'ai pas excel sous les yeux ici mais ca doit etre comme ca je pense.

Ca se complique un peu si toutes les feuilles ne sont pas dans le meme classeur, mais ja crois qu\'il suffit de maintenir \"control\" pour selectionner les cellules voulues
et de passer par cette fonction (en gros) [:D]

Bon courage



denrose90 denrose90
275 contributions
Membre depuis le 15/08/2005
Envoyé le 09/04/2009 à 11:22


Bonjour,

vois avec la fonction somme.si mais il va falloir rajouter une colonne de 1
il y a surement mieux mais je ne sais pas si je trouve je te dit
salut à toutes et à tous
* Cadocin
Anonyme
Envoyé le 09/04/2009 à 12:57 Modifié par Cadocin le 09/04/2009 à  13:17

Bonjour,

Il faut utiliser la fonction NB.SI()

Si tes oui, non, nc se trouvent dans une colonne formant une plage B1:B24 par exemple, pour le nombre de oui, la formule est :

=NB.SI(B1:B24;"oui")

même chose pour NC et NON

Bien sur tenir compte du nom de la feuille. Faire les 3 calculs pour les 3 feuilles dans une cellule cachée de la 4° feuille, puis totaliser les résultats.

Pegase Pegase
1 023 contributions
Membre depuis le 07/02/2002
Envoyé le 09/04/2009 à 13:52 Modifié par Pegase le 09/04/2009 à  13:52:


Bonjour,

Solution en une seule formule sans cellules cachées dans la feuille 4
En supposant que les plages à explorer dans les feuilles 1 à 3 soit B1:B24
Dans la cellule comptabilisant les Oui de la feuilles 4 écrire :

=NB.SI(Feuil1!B1:B24;"Oui")+NB.SI(Feuil2!B1:B24;"Oui")+NB.SI(Feuil3!B1:B24;"Oui")

Même chose avec Non et NC

Avantage : Pas de cellules de calcul intermédiaire
Moi, le jour où j'aurai vraiment mon âge, je mourrai (Léo Ferré).
* Cadocin
Anonyme
Envoyé le 09/04/2009 à 14:49

Bonjour,

Exact. Une seule formule longue à la place de 3 courtes. L\'essentiel étant de connaître la fonction à utiliser. Ensuite on peut toujours composer.

Discussion trop ancienne

Cette discussion a été automatiquement fermée car elle n'a plus reçue de nouveau message depuis trop longtemps.

Nous vous suggérons de créer un nouveau message

« Retour sur la liste des messages de ce forum