incrementer les lignes au fur a mesure de nouvelles saisies

pat40 pat40
86 contributions
Membre depuis le 04/03/2011
Envoyé le 27/11/2011 à 21:45


Bonjour,
Bonjour, Bonjour
Je fais mes premiers pas en VBA, Je cherche le code pour incrémenter :
les lignes au fur à mesure de nouvelles saisie. Je souhaite numéroter la première ligne vide d'une base sous forme de feuille excel avec un userforme que j'ai créer , un textbox col A nommée ordre (afin de mettre le n°), un textbox col B nommée nom. J'ai recherché sur la toile mais bon... cela parait moins simple à mettre en oeuvre .. Si quelqu'un peut me donner un coup de main, je peux envoyer le doc pour mieux me faire comprendre merci 


Pegase Pegase
1 023 contributions
Membre depuis le 07/02/2002
Envoyé le 28/11/2011 à 00:17


Bonjour,

Je ne sais pas si j'ai bien compris ce que tu veux faire.
Il y a une possibilité sans créer une macro VBA
Dans la cellule de la 1ière ligne tu tapes 0
Dans la cellule de la 2ième ligne tu tapes =(A1+1)
Dans la cellule de la 2ième ligne tu tapes =(A2+1)
etc...
Si tu veux asservir le n° de ligne au fait que la colonne B ne soit pas vide par exemple, tu tapes
ligne 1 =SI(B1=0;"";0)
ligne 2 =SI(B2=0;"";A1+1)
ligne 3 =SI(B3=0;"";A2+1)
ligne 4 =SI(B4=0;"";A3+1)

Si cela ne correspond pas à ce que tu veux faire, envoie un fichier via www.cijoint.fr
Moi, le jour où j'aurai vraiment mon âge, je mourrai (Léo Ferré).
pat40 pat40
86 contributions
Membre depuis le 04/03/2011
Envoyé le 28/11/2011 à 06:22


Bonjour,
merci pour ta réponse, mais je souhaite du code bva et
je ne sais pas pourquoi mais le lien sur ww.cijoint.fr via google chrome ne se fait pas, pas plus que par internet explorer
je souhaite t'envoyer le fichier mais bon...


Pegase Pegase
1 023 contributions
Membre depuis le 07/02/2002
Envoyé le 28/11/2011 à 13:37 Modifié par Pegase


Bonjour,

Effectivement www.cijoint.fr ne fonctionne pas (ou plus pour l'instant [:(])
tu peux utiliser www.partage-fichiers.com
ou dl.free
Moi, le jour où j'aurai vraiment mon âge, je mourrai (Léo Ferré).

Discussion trop ancienne

Cette discussion a été automatiquement fermée car elle n'a plus reçue de nouveau message depuis trop longtemps.

Nous vous suggérons de créer un nouveau message

« Retour sur la liste des messages de ce forum