Excel : Probleme dans une regle de recherche de mots dans un texte

* userjf2007@gmail.com
Anonyme
Envoyé le 16/01/2012 à 23:56

Bonjour


j'ai une regle présente en colonne D qui doit rechercher la présence des sequences ", par" ou "? Par" décrite dans la deuxieme feuille de calcul "TABLE-REF" dans les textes en colonne C

Resultat
- Ligne 2 : le resultat attendu est "NC" car ", par" ou "? Par" n'est pas présent
- Ligne 3 : le resultat attendu est "parties, simulation et société fictive," car ", par" est présent et je récupère ce qui est derière
" - Ligne 4 : le resultat attendu est ""NC"" car "", par"" ou ""? Par"" n'est pas présent
=> PROBLEME la regle trouve ""par"" et donne un faux resultat"


=> Comment faire en sorte que la regle ne fonctionne pas avec "par" mais uniquement avec ce que j'ai indiqué dans la feuille "TABLES-REF" soit ", par"


Les 3 lignes de textes:
1 : Conclusion d'un contrat, consentement des patrties, simulation et société fictive,
2 : Conclusion d'un contrat, consentement des , parties, simulation et société fictive,
3 : Conclusion d'un contrat, consentement des parties, simulation et société fictive,

Les 3 resultats avec la regle
1 : NC
2 : parties, simulation et société fictive,
3 : parties, simulation et société fictive,

les 3 resultats attendus
1 : NC
2 : parties, simulation et société fictive,
3 : NC


la regle:

=SI( SOMME( ( ESTNUM( CHERCHE( SUBSTITUE( 'TABLES-REF'!$B$5:$B$6;"""";"");C2 ) ) ) *1) =0; "NC"; DROITE(C2;(NBCAR(C2))-(CHERCHE( INDEX( 'TABLES-REF'!$B$5:$B$6; EQUIV( VRAI; ESTNUM( CHERCHE(SUBSTITUE('TABLES-REF'!$B$5:$B$6;"""";"");C2 ) );0 ) );C2))) )






merci d'avance

Mytå_Qc Mytå_Qc
30 contributions
Membre depuis le 06/08/2010
Envoyé le 17/01/2012 à 01:15


Bonjour,
Solution donnée sur un autre forum


texte_cherché est le texte que vous voulez trouver. Vous pouvez utiliser les caractères génériques, le point d'interrogation (?) et l'astérisque (*) dans l'argument texte_cherché. Un point d'interrogation correspond à un caractère unique quelconque et l'astérisque correspond à une séquence de caractères quelconque. Si vous voulez trouver réellement un point d'interrogation ou un astérisque, tapez un tilde (~) devant ce caractère.


Tes critères deviennent :
B5 : ', par et B6 : '~? par





Discussion trop ancienne

Cette discussion a été automatiquement fermée car elle n'a plus reçue de nouveau message depuis trop longtemps.

Nous vous suggérons de créer un nouveau message

« Retour sur la liste des messages de ce forum