Publipostage avec image ou publimage

cjik1
1 contribution
Membre depuis le 18/12/2016
Envoyé le 18/12/2016 à 00:28


Bonsoir aux membres du FORUM,
J'ai besoin de réaliser un publipostage, ayant crée une base de donnée dans Excel contenant le champ NOM et images.
dans Excel:
champ nom=LESSA
champ image= C:\\Temp\Images\\cache.png
j'utilise word 2007
Dans ma lettre type j'ai inséré le champ convenablement.
dans le champ image, j'ai inséré ceci: { INCLUDEPICTURE "{ MERGEFIELD images }" \d }

Mon problème: quand je fusionne, le champ nom affiche bien ce qui est juste mais le champ image affiche un cadre avec une croix a l'angle haut et gauche, je ne voie pas l'image,
je prends bien le soin d'appuyer ctrl+A et F9 et parfois même ALT+F9

je vous prie de bien vouloir m'aider et merci d'avance de l'importance que vous accorderez a mon sujet.




Claude40 Claude40
1 530 contributions
Membre depuis le 24/03/2010
Envoyé le 18/12/2016 à 21:07


Bonjour,
J'ai fait des essais, mais je n'affiche qu'une seule image, la première de la base de données.
Concernant le cadre avec la croix à la place de l'image, il signifie que l'image n'a pas été trouvée à l'adresse indiquée.
Personnellement, j'ai utilisé la procédure "standard" et elle n'a pas généré de guillemets ni d'accolades de part et d'autre de MERGEFIELD. L'erreur vient peut-être de là.! Je n'ai pas non plus utilisé l'option \d, qui lie les images au lieu de les stocker dans le document WORD de sortie.
Je poursuis mes recherche pour essayer d'avoir une image propre à chaque ligne de la base de données.
Un bon exposé du problème, c'est déjà un grand pas vers la solution. Dans la mesure du possible, mes solutions sont testées, sur mon système actuel (W10 Pro version 1909), mais peuvent ne pas fonctionner sur tous les Pc
Claude40 Claude40
1 530 contributions
Membre depuis le 24/03/2010
Envoyé le 19/12/2016 à 16:40


Bonjour,

Après bien des recherches, je pense avoir trouvé une solution qui suppose plusieurs choses :
1) Il semble qu’il y ait un bug pour les versions 2007 et antérieures et qu’il faille travailler en mode compatibilité, donc enregistrer le modèle Word au format 1997-2003.
2) Dans ce cas, il est impératif d’utiliser le double slashback pour le chemin d’accès aux images.
3) Il ne faut pas passer par « Aperçu des résultats ». Utiliser directement « Terminer & fusionner »
4) Aucune image n’apparait dans un premier temps sur le fichier Word de sortie. Faire « CTRL + A » pour sélectionner tout, puis « F9 » pour mettre à jour les champs.
5) Voici le modèle de code que j’obtiens pour les fonctions « INCLUDEPICTURE et MERGEFIELD ». Cela fonctionne aussi avec « \d »
Sur la feuille modèle : {INCLUDEPICTURE “{MERGEFIELD “Image”}”}. « Image » est le nom du champ de ma base de données.
Sur la feuille fusionnée : {INCLUDEPICTURE “D :\\phn.jpg”}. J’ai mis mes images à la racine de D : pour simplifier. J’ai bien un phn différent pour chaque nom de destinataire.

Un bon exposé du problème, c'est déjà un grand pas vers la solution. Dans la mesure du possible, mes solutions sont testées, sur mon système actuel (W10 Pro version 1909), mais peuvent ne pas fonctionner sur tous les Pc

Discussion trop ancienne

Cette discussion a été automatiquement fermée car elle n'a plus reçue de nouveau message depuis trop longtemps.

Nous vous suggérons de créer un nouveau message

« Retour sur la liste des messages de ce forum