Pavé numérique désactivé suivant la session... (résolu)

* emarie3680
Anonyme
Envoyé le 28/08/2017 à 10:20

Bonjour,

Je suis sous Windows 10 édition familiale. Mon PC est un portable de chez Asus (S550C) qui fonctionne très bien ... à un détail près.
Lorsque je suis sous ma session, le pavé numérique est activé.
Lorsque je crée un nouvel utilisateur, que ce soit via les paramètres de Windows ou la console (cmd en mode admin), le pavé numérique numérique n'est plus activé !
C'est incroyable, le voyant est allumé jusqu'au niveau de l'écran où les différentes sessions sont proposées.
Je choisis la mienne, le voyant est allumé, le pavé numérique est actif.
Si je choisis une autre session, le voyant s'éteint et le pavé numérique n'est plus actif.
C'est à se casser la tête. J'ai essayé la solution qui est préconisée de partout : changer la valeur InitialKeyboardIndicators à 2 de partout dans la base de registre et en désactivant l'option de démarrage rapide.
J'ai ce problème quel que soit le compte que je crée : admin ou user.
Je n'ai pas l'option dans le BIOS qui permet de l'activer automatiquement.
Avec l'aide d'une technicien Microsoft et à distance, les fichiers système ont été réinstallés Rien n'y fait...
Je fais donc appel à vous car là, je suis dépassé !!!
Merci d'avance,
Éric

Claude40 Claude40
1 533 contributions
Membre depuis le 24/03/2010
Envoyé le 28/08/2017 à 11:24


Bonjour,
Un question préliminaire : Est-ce que le pavé réagit en déplaçant le curseur selon les flèches qui figurent sur les touches 2,4,6,8 , par exemple ?
Si Oui, cela veut dire que le pavé numérique est désactivé pour sa fonction numérique et utilisable uniquement pour effectuer les déplacements de curseur avec la souris (Option d’ergonomie).
Pour remédier à ce problème, il faut aller dans les Options d’ergonomie du Panneau de Configuration, puis cliquer sur « Rendre le clavier plus facile à utiliser » et décocher « Activer les touches souris ».
Si Non : pas d’idée pour le moment.
Un bon exposé du problème, c'est déjà un grand pas vers la solution. Dans la mesure du possible, mes solutions sont testées, sur mon système actuel (W10 Pro version 1909), mais peuvent ne pas fonctionner sur tous les Pc
emarie3680
4 contributions
Membre depuis le 27/08/2017
Envoyé le 29/08/2017 à 21:58


Bonjour Claude40,
et un grand merci pour votre réponse...
Cette fonction n'est pas activée dans mes options d'ergonomie... désolé. En revanche, oui, les touches directionnelles sont activées...
Ce qui est génial est que dans la base de registre la clé InitialKeyboardIndicators se remet seules à 0 alors que je l'avais réglée à 2 pour la/les session/s en question. Je pense que mon PC est hanté.
Cependant, je peux activer mon pavé numérique "manuellement" (touche fn + num lk). Dons tout n'est pas perdu c'est juste embêtant lorsque l'on a des mots de passe alphanumériques...

Bien cordialement,

Éric



Claude40 Claude40
1 533 contributions
Membre depuis le 24/03/2010
Envoyé le 30/08/2017 à 09:24


Bonjour,
Il y a deux clés de registres pour le pavé numérique.
Une clé sous HKEY_CURRENT_USER (utilisateur en cours) et une clé sous HKEY_USERS (Tous utilisateurs)
Avez-vous mis les deux à 2 ?
NB chez moi (sur un pc fixe W10 Pro), la première est à 2 et la seconde à 2147483648 ( ??)

Un bon exposé du problème, c'est déjà un grand pas vers la solution. Dans la mesure du possible, mes solutions sont testées, sur mon système actuel (W10 Pro version 1909), mais peuvent ne pas fonctionner sur tous les Pc
emarie3680
4 contributions
Membre depuis le 27/08/2017
Envoyé le 30/08/2017 à 09:38


Bonjour Claude,

En effet, j'ai bien mis les deux clés à 2.
J'ai également désactivé le démarrage rapide dans les options avancées d'alimentation.
Je pense qu'il ne reste plus qu'à faire appel à un désenvouteur...

Bonne journée et encore merci pour votre aide.

Éric

Claude40 Claude40
1 533 contributions
Membre depuis le 24/03/2010
Envoyé le 30/08/2017 à 10:15


Bonjour,
J'ai vu une autre "astuce" sur le net, mais elle me paraît très empirique, même si certains disent qu'elle a fonctionné :
A faire pour chaque session :
Activer manuellement le clavier numérique (témoin lumineux allumé).
Commander l'arrêt de Windows.
Pendant le processus d'arrêt, refaire fn + NumLock lorsque le voyant s'éteint et ce jusqu'à ce que le portable soit complètement arrêté.
Certains disent qu'au démarrage le clavier numérique est bien activé.
Il faut peut être recommencer plusieurs fois la manip, car il semble nécessaire que fn + numLock soit fait à un moment très précis (mais impossible à situer exactement) du processus de fermeture.
C'est un peu comme quand il fallait appuyer sur une touche fx au démarrage pour faire un démarrage sans échec. Le moment ou la touche agissait était difficile a déterminer.
Un bon exposé du problème, c'est déjà un grand pas vers la solution. Dans la mesure du possible, mes solutions sont testées, sur mon système actuel (W10 Pro version 1909), mais peuvent ne pas fonctionner sur tous les Pc
emarie3680
4 contributions
Membre depuis le 27/08/2017
Envoyé le 30/08/2017 à 11:20


Merci pour cette astuce que je ne connaissais pas...
Je testerai ce soir et vous tiendrai au courant, après plusieurs essais vu qu'il y a un facteur aléatoire... !

À plus tard donc et bonne journée !!

Éric



emarie3680
4 contributions
Membre depuis le 27/08/2017
Envoyé le 30/08/2017 à 16:55


Rebonjour Claude,

J'ai essayé cette dernière astuce et ... ça fonctionne ! Comment, pourquoi... ? Il doit y avoir une raison logique mais elle m'échappe...

En tout cas un grand grand merci pour votre aide !!

Très bonne continuation,

Éric



Claude40 Claude40
1 533 contributions
Membre depuis le 24/03/2010
Envoyé le 31/08/2017 à 20:47 Modifié par Claude40


Bonjour,
Comprendre la raison logique qui fait que la manip a résolu le problème est en effet le prochain sujet de recherche.
Pour expliquer le fait qu'une clé de registre, revienne automatiquement à la valeur par défaut, il faut chercher, à mon avis, en dehors de Windows. J'ai en effet la certitude que des logiciels externes (des gestionnaires de la marque du pc ou des antivirus notamment) forcent la valeur de certaines clés de registres ce qui les aide dans leurs actions propres en interdisant aux utilisateurs des modifications génératrices de difficultés. C'est la cas par exemple des antivirus qui remettent à leur valeur par défaut les clés de registre qui commandent l'exécution automatique des supports externes USB, ceci pour désactiver cette même exécution automatique jugée dangereuse pour l'intégrité du pc.
Peut-on en conclure que la réinitialisation des valeurs par défaut de la clé de registre dans le cas du clavier numérique est provoquée par un processus "non Windows"?
Il faudrait l'avis d'experts plus pointus dans le domaine "système".
Un bon exposé du problème, c'est déjà un grand pas vers la solution. Dans la mesure du possible, mes solutions sont testées, sur mon système actuel (W10 Pro version 1909), mais peuvent ne pas fonctionner sur tous les Pc
* fandeu2
Anonyme
Envoyé le 04/09/2017 à 10:56

Bonjour,
un grand merci. J'ai écumé pas mal de forums (j'ai aussi un asus S550C) et le fait d'appuyer sur la touche Fn+la touche NumLock a fonctionné à la fermeture de windows!!!
Merci pour l'astuce!!!


J_D J_D
10 736 contributions
Membre depuis le 12/11/2001
Envoyé le 04/09/2017 à 11:54


Bonjour,
Merci du retour (+)

Je ne réponds pas aux messages privés non sollicités ! C'est pas toujours facile...
Claude40 Claude40
1 533 contributions
Membre depuis le 24/03/2010
Envoyé le 04/09/2017 à 13:37


Bonjour,
Je suis heureux que l'astuce aie pu servir à plusieurs personnes !
Merci des retours qui ont deux vertus : confirmer l'aspect "généralisable" d'une solution et faire plaisir à ceux qui passent un peu de temps à proposer des solutions.

Un bon exposé du problème, c'est déjà un grand pas vers la solution. Dans la mesure du possible, mes solutions sont testées, sur mon système actuel (W10 Pro version 1909), mais peuvent ne pas fonctionner sur tous les Pc

Discussion trop ancienne

Cette discussion a été automatiquement fermée car elle n'a plus reçue de nouveau message depuis trop longtemps.

Nous vous suggérons de créer un nouveau message

« Retour sur la liste des messages de ce forum