Formules imbriquées "SI"

akon_aug akon_aug
510 contributions
Membre depuis le 08/03/2007
Envoyé le 08/02/2018 à 17:56


Bonjour,
Bonjour à Tous

Je sèche sur un problème en EXCEL, malgré les cours et formules déjà proposés sur Internet.
Il s'agit de la formule "SI"
J'ai 2 cellules : B5 et C5

si la valeur de B5 est comprise entre 0-5, écrire "REFAIRE" en C5
si la valeur de B5 est comprise entre 6-9, écrire "PASSER" en C5
Si la valeur de B5 est comprise entre 10-15, écrire "STOP" en C5
Si la valeur de B5 est comprise entre 16-20, écrire "FIN" en C5.

Je n'ai pas pu m'en sortir, vraiment qu'un Crack en EXCEL me sorte d'affaires...

Merci Beaucoup

Voir fichier joint

MS Office 2013




AKON
gaston gaston
1 474 contributions
Membre depuis le 01/03/2001
Envoyé le 08/02/2018 à 19:53 Modifié par gaston


Bonjour,

si tu as une version d'au moins 2016 ces fonctions devraient t'aider:
SI.CONDITIONS()

Si.MULTIPLE()

ça devrait donner quelque chose dans ce goût-là :

=SI.CONDITIONS(OU(B5>=0;B5<=5);"refaire";OU(B5>=6;B5<=9);"PASSER";OU(B5>=10;B5<=15);"stop";OU(B5>=16;B5<=20);"fin")

j'ai pas testé parce que ma version est d'avant 2016 :-(
ah zut, je viens de voir que toi aussi

alors je pense qu'il faut passer par des ET ou des OU imbriqués en plus des SI, mais ça va être une usine à gaz...

voir ici: fonction SI imbriquées

essaie ça, peut-être ?
=SI(OU(B5>=0;B5<=5);"repasser";SI(OU(B5>=6;B5<=9);"passer";SI(OU(B5>=10;B5<15);"stop";SI(OU(B5>=16;B5<20);"fin";"hors conditions"))))

mais je ne suis pas un spécialiste...

carpe diem
Bipbipcoyote Bipbipcoyote
3 000 contributions
Membre depuis le 06/03/2001
Envoyé le 09/02/2018 à 03:09 Modifié par Bipbipcoyote


Bonjour,
il faut démarrer "petit", c'est à dire commencer par la première partie
=SI(ET(B5>-1;B5<6);"REFAIRE";"")
Ceci teste SI B5 est plus grand que -1 donc 0 ET Si B5 est plus petit que 6 donc 5,4,3,2,1,0 , Si VRAI alors afficher REFAIRE sinon ne rien afficher ""
Quand cette première partie fonctionne alors il suffit de recopier la fonction avant la condition FAUSSE
comme ceci (sans oublier d'ajouter une parenthèse fermante à la fin)
=SI(ET(B5>-1;B5<6);"REFAIRE";SI(ET(B5>5;B5<10);"PASSER";""))
On poursuit de la même façon
=SI(ET(B5>-1;B5<6);"REFAIRE";SI(ET(B5>5;B5<10);"PASSER";SI(ET(B5>9;B5<16);"STOP";"")))
et finalement
=SI(ET(B5>-1;B5<6);"REFAIRE";SI(ET(B5>5;B5<10);"PASSER";SI(ET(B5>9;B5<16);"STOP";SI(ET(B5>14;B5<21);"FIN";""))))

Si vous abordez le problème dans son ensemble, cela peut s'avérer plus difficile à résoudre. Il faut découper les actions une à une et c'est beaucoup plus facile
Maintenant,il faut voir quelle version d'Excel vous utilisez car si je me souviens bien, il y avait une limitation à 3 conditions maximum. On peut alors passer par VBA

Private Sub Worksheet_SelectionChange(ByVal Target As Range)
Select Case Range("B5")
Case 0 To 5
Range("C5") = "REFAIRE"

Case 6 To 9
Range("C5") = "PASSER"

Case 10 To 15
Range("C5") = "STOP"

Case 16 To 20
Range("C5") = "FIN"

Case Else
Range("C5") = ""
End Select
End Sub
à copier dans le VBE de la Feuille (donc faire alt+F11, double cliquer sur le nom de la feuille et copier le code ci-dessus. retourner sur la feuille et modifier la cellule B5, logiquement la cellule C5 s'adaptera
Visitez mon Site Google est mon ami, il répond mieux que moi, posez lui d'abord vos questions
akon_aug akon_aug
510 contributions
Membre depuis le 08/03/2007
Envoyé le 09/02/2018 à 16:46


Bonjour,
Bonjour à tous
Merci à bipbipCoyote

La formule marche bien chez moi, sans passer par le VBA

Merci
AKON
Claude40 Claude40
1 531 contributions
Membre depuis le 24/03/2010
Envoyé le 09/02/2018 à 21:01 Modifié par Claude40


Bonjour,
Je pense qu’il n’est plus utile d’utiliser « Si(ET » à partir du deuxième « SI ». Puisque ce « Si » (et les suivants) s’exécute (ent) si la condition précédente est « faux », le ET est redondant.

=SI(ET(B5>-1;B5<6);"REFAIRE";SI(B5<10;"PASSER";SI(B5<16;"STOP";SI(B5<21;"FIN";""))))

Mais je chipote ! [:o)]
Un bon exposé du problème, c'est déjà un grand pas vers la solution. Dans la mesure du possible, mes solutions sont testées, sur mon système actuel (W10 Pro version 1909), mais peuvent ne pas fonctionner sur tous les Pc

Discussion trop ancienne

Cette discussion a été automatiquement fermée car elle n'a plus reçue de nouveau message depuis trop longtemps.

Nous vous suggérons de créer un nouveau message

« Retour sur la liste des messages de ce forum