Copie cellules excel dans une meme feuille sous condition

* alphi500
Anonyme
Envoyé le 23/11/2021 à 22:12

Bonjour,
je souhaite copier le contenu de cellules dans d'autres dans la meme feuille excel sous condition
si b2=1 copier b3 en b4
copier c3 en c4
copier d3 en d4
et ceci sans passer par VBA si possible merci pour vos réponses


Bipbipcoyote Bipbipcoyote
3 736 contributions
Membre depuis le 06/03/2001
Envoyé le 24/11/2021 à 02:39 Modifié par Bipbipcoyote


Bonjour,
il faut simplement mettre en B4
=Si($B$2=1;B3;"")
idem en C4
=Si($B$2=1;C3;"")
et en D4
=Si($B$2=1;D3;"")
Et protéger les cellules pour ne pas écraser les formules
Comme les $ indiquent que B2 est en référence absolue, tu peux simplement mettre la formule en B4 et faire un copier-coller dans les 2 autres cellules (C4,D4)

Je devine que tu es débutant en Excel, je te conseille de suivre les cours de Loïc et Julien et de leur copine
Visitez mon Site Google est mon ami, il répond mieux que moi, posez lui d'abord vos questions
* alphi500
Anonyme
Envoyé le 26/11/2021 à 11:01

Bonjour,
merci pour la réponse mais je n'ai pas formulé entièrement ma question
si b2=0 je veux garder la valeur en b4 et avoir la possibilité de soustraire b3 de b4 dans b5
b2=0 b3=100 b4=70 b5=30
b2=1 b3=100 b4=100 b5=0
si b2 revient à 0 b3=100 b4=100 b5=0
par la suite b3 s'incrémente b3=110 b4=100 b5=10
b2 revient à 1 b3=110 b4=110 b5=0
suis-je plus clair
merci pour la suite

Bipbipcoyote Bipbipcoyote
3 736 contributions
Membre depuis le 06/03/2001
Envoyé le 26/11/2021 à 17:20 Modifié par Bipbipcoyote


Bonjour,
Ce n'est pas ta question de départ, car le résultat de ta demande, B3 et B4 auraient contenu la MEME valeur mais soit...
Si tu modifies le contenu de B3 et/ou B4. Il faut mettre la formule en B5
=SI($B$2=0;B3-B4;0)
ce qui signifie en français, si B2 est égal à 0 alors B3-B4 sinon 0
donc si tu places autre chose que 0 en B2 que ce soit un autre nombre ou une lettre tu obtiens 0 en B5
Lorsqu'une des valeurs en B3 ou B4 est modifiée le calcul est refait automatiquement
maintenant tu ne dis pas comment tu incrémentes le contenu de B3 et B4, ici je suppose que tu les modifies "manuellement" parce que cette incrémentation ne va pas se faire par la volonté du St Esprit, elle est sans doute provoquée par une autre condition rencontrée ailleurs sur ton fichier
Visitez mon Site Google est mon ami, il répond mieux que moi, posez lui d'abord vos questions

Discussion trop ancienne

Cette discussion a été automatiquement fermée car elle n'a plus reçue de nouveau message depuis trop longtemps.

Nous vous suggérons de créer un nouveau message

« Retour sur la liste des messages de ce forum