Probleme de publipostage

cameleon30 cameleon30
784 contributions
Membre depuis le 25/06/2001
Envoyé le 14/09/2005 à 17:51


Bonjour,

J\'ai une base de donnée sous Excel avec quelques calcul. Je veux importer certaines données sous Word pour faire un publipostage. Jusque la aucun probleme.
Quand je fusionne un chiffre (qui a des 2 decimal par exemple 20,65), Word me sort un chiffre de la sorte 20,649999999999999999.
Au début, je pensai que ca venait de mes calculs mais j\'ai essaye de faire un publipostage juste avec un chiffre et c la meme chose.
J\'ai essaye de changer le format du calcul en passant de standard, en le mettant en nombre ... sous excel mais c pareil
Pourquoi word me change ce chiffre qui fausse apres tout mon publipostage. Et j\'ai pas envie de me saisir tout c chiffre a la main car il doit y en avoir plus de 10000. Je vous explique pas le boulot [:(] [:D] [:D]
Une solution (?)
http://www.helpclic.net
Mylene Mylene
5 653 contributions
Membre depuis le 06/01/2003
Envoyé le 15/09/2005 à 06:39


Peut-être en activant l\'option dans Excel :

Outils > Options > Calcul > Calcul avec la précision au format affiché
domyfr domyfr
1 154 contributions
Membre depuis le 20/02/2002
Envoyé le 15/09/2005 à 09:04


je vois que word fait toujours la même erreur
il interprète un résultat d\'excel en effet si la cellule dans excel est une valeur entré au clavier, cela ne pose pas de problème dans Word, mais si le nombre est un résultat (d\'une adition de celleule par exemple) Word se plante lamentablement.

comment je l\'avais résolu :
dans excel faire une autre colonne à coté, la passer en format : texte, et inclure avec une formule le résultat de ta colonne chiffre.
formule simple : =TEXTE(;A1)
attention dans le cas d\'un résultat : 123,45 le résultat texte est 123,45 mais dans le nombre 123,00 le résultat est 123 sans l\'affichage des décimals ....

pour avoir l\'affichage des décimals, il faut passer par un SI qui teste la partie entière du nombre le compare avec le nombre et le tour est joué : voila la formule avec explications

=SI(TRONQUE(A2)=A2;TEXTE(;B2)&\",00\";TEXTE(;B2))


TRONQUE : renvoie le nombre sans ses décimals.
exemple pour 123,45 il renvoie 123 seulement en fait c\'est la partie entière du nombre.

donc si la cellule A2 à le résultat affiché de 123,00, tronque donne la valeur 123, on teste si elle est pareil à A2, c\'est le cas, alors on prend le texte du chiffre de A2 soit 123 on y ajoute ,00 résultat 123,00 à l\'affichage texte.

si le test est négatif

exemple A2 = 123,45, TRONQUE nous rapporte 123 on test si ce nombre (123) est pareil que A2 (123,45) ce n\'est pas le cas alors on prent la partie texte du nombre seulement.

Voici Voila

Si tu n\'a pas tout compris demande

cameleon30 cameleon30
784 contributions
Membre depuis le 25/06/2001
Envoyé le 15/09/2005 à 15:49


Ok merci ca fonctionne. Il aurait pu quand même verifier ca les programmeurs de microsoft
http://www.helpclic.net
johannis johannis
19 917 contributions
Membre depuis le 10/10/2001
Envoyé le 15/09/2005 à 17:48


Il aurait pu quand même verifier ca les programmeurs de microsoft



ouah, l\'autre, et la marmotte... le chocolat et le papier d\'argent, toussa [°)] [:D]
faut pas rêver.

louma louma
144 contributions
Membre depuis le 21/02/2003
Envoyé le 18/09/2005 à 22:09


Bonsoir,
Les programmeurs de Microsoft ont prévu !!

Pour que tes nombres s\'affichent par exemple avec 2 décimales tu dois ajouter le commutateur \\#
exemple :
{MERGEFIELD NOMBRE\\#\"# #00,00\"
NOMBRE étant le nom que j\'ai donné à mon champ pour tester.


domyfr domyfr
1 154 contributions
Membre depuis le 20/02/2002
Envoyé le 19/09/2005 à 10:10


{MERGEFIELD NOMBRE\\#\"# #00,00\"

Ouais mais il n\'y a qu\'un petit défaut à cette formule :
Dans certains, voir beaucoup, de cas nous pouvons avoir 122,99999999999999999 comme résultat dans word, alors que dans excel la cellule affiche 123,00, et que le résultat du calcul (fait avec calculette scientifique ou pas) est bien 123,00, alors avec MERGEFIELD on optien 122,99 ....
Ne me demandez pas pourquoi je ne me suis pas penché sur la raison exact de ce fénomène, mais je me rappel que les début de excel sous windows2 rendaient des résultats de ce genre et avait été corigé dans les version suivante, est ce que ce problème redeviens récurant dans Word, qui je vous le rappel est un Traitement de texte et non une valeur sur en calcul.

dailleurs essayez ceci :

Ouvrez un document Word vierge
tapez, sans espaces cette formule : =rand(200,99)
Et ensuite faite \"entrer\"

Etonant non ?

aller ! bonne journée et ne buvez pas trop de bière par contre manger que des kiwis ... c\'est tres bon pour la santée ....
domyfr domyfr
1 154 contributions
Membre depuis le 20/02/2002
Envoyé le 19/09/2005 à 10:18


j\'oubliais pour les versions Anglaise de Word, ou certaine version anglophone c\'est :

aller ! bonne journée et ne jouer pas à saute mouton mais plus tot à saute chien, et ne tué pas le renard ...

* Agnès
Anonyme
Envoyé le 18/01/2011 à 14:31

Il suffit de transformer la colonne des résultats de calcul dans excel sous un format "texte" et ca marche

Discussion trop ancienne

Cette discussion a été automatiquement fermée car elle n'a plus reçue de nouveau message depuis trop longtemps.

Nous vous suggérons de créer un nouveau message

« Retour sur la liste des messages de ce forum