pb bouton ds un formulaire

datasoft datasoft
247 contributions
Membre depuis le 26/01/2003
Envoyé le 12/04/2006 à 00:56


Salut,
lorsque j\'ajoute un bouton a un formulaire et apres le definition des pptés, j\'obtiens tjs le message suivant apres le cilc:
UN PB EST SURVENU DURANT LA COMMUNICATION ENTRE ACCESS ET LE SERVEUR OLE OU LE CONTRE ACTIVEX.
c\'est access2003
merci
spiralbol spiralbol
5 370 contributions
Membre depuis le 11/02/2003
Envoyé le 12/04/2006 à 08:04


salut

ce message indique que ton bouton ouvre une aplication externe a ACCESS, et la liaison na ce fait pas, le serveur OLE c\'est le nom donné a la liaison entre application windows et particulierement office, comme par exemple ouvrir une feuille EXELS dans ACCESS.

cela serait bien que tu précise ce que le bouton est chargé d\'ouvrir [:D]
Mylene Mylene
5 653 contributions
Membre depuis le 06/01/2003
Envoyé le 12/04/2006 à 15:43 Modifié par Modifié par mylene. le 12/04/2


- Vérifier les paramètres de sécurité : Outils > Macros > Sécurité, sélectionner \"Niveau de sécurité moyen
- Vérifier aussi les autorisations d\'accès au niveau utilisateur (Outils > Sécurité > Autorisations d\'accès)
- Il y a des antécédents avec Norton : support.microsoft.com/default.aspx?scid=kb;fr;295824, désactiver temporairement Norton pour savoir s\'il n\'est pas en cause.
- Dans le cas où une image est employée, il faut que Microsoft photo editor soit installé pour que l\'image puisse être visionnée

datasoft datasoft
247 contributions
Membre depuis le 26/01/2003
Envoyé le 14/04/2006 à 12:58


en faite, il n \'y a ni fichier excel,ni image,Sécurité à \"Niveau de sécurité bas\"
..je veux simplement aller d\'un formulaire a un autre a l\'aide des boutons->je choisis operations sur formulaires->ouvrir ou fermer formulaire...
ds le message d\'erreur UN PB EST SURVENU DURANT LA COMMUNICATION ENTRE ACCESS ET LE SERVEUR OLE OU LE CONTROLE ACTIVEX.
spiralbol spiralbol
5 370 contributions
Membre depuis le 11/02/2003
Envoyé le 14/04/2006 à 22:25


etonant la communcation entre formulaire dans ACCESS ce fait a travers un macro en visual basic

a tu installé l\'asistant VISUAL BASIC lors de l\'installation d\'ACCESS, parce que dans le cas contraire les macro ne fonctionne pas, donc impossible d\'utiliser les commande predefini dans les propriété [°)]
Mylene Mylene
5 653 contributions
Membre depuis le 06/01/2003
Envoyé le 15/04/2006 à 10:28



Apparemment, ce problème est assez récurrent. J\'imagine que la base de données que tu exécutes est bien sur ta machine (sinon, on aurait pu se diriger vers un problème réseau... communication PC --> PC serveur)

Bon... je n\'aime pas trop cela parce que finalement, si cela peut résoudre le problème, on n\'en connaît toujours pas l\'origine pour autant : essaie de créer une nouvelle base de données et d\'importer vers elle, tous tes objets de cette base qui te pose problème... tous sans exception.

Désolée, je n\'ai pas mieux [8(] ... il est toujours un peu difficile de résoudre ce genre de problème lorsque l\'on n\'a pas la base en main... et que l\'on n\'est pas une pro du visual basic.
spiralbol spiralbol
5 370 contributions
Membre depuis le 11/02/2003
Envoyé le 15/04/2006 à 12:49


il est toujours un peu difficile de résoudre ce genre de problème lorsque l\'on n\'a pas la base en main... et que l\'on n\'est pas une pro du visual basic.



effectivement, il existe 3 façon d\'adresser un formaire, donc............
datasoft datasoft
247 contributions
Membre depuis le 26/01/2003
Envoyé le 21/04/2006 à 23:46 Modifié par Modifié par datasoft le 22/04/


j\'ai créé un splashscreen et j\'ai tjs l\'erreur suivante:
UN PB EST SURVENU DURANT LA COMMUNICATION ENTRE MABASE ET LE SERVEUROLE OU LE CONTROLE ACTIVX.je sais pas est ce qu\'il me manque qcq chose a installer ou quoi.la base est sur mon pc,pas de reseau...
y a t il un expert en access?
Merci
spiralbol spiralbol
5 370 contributions
Membre depuis le 11/02/2003
Envoyé le 22/04/2006 à 13:25


a mon avis il faut regarder du coté du visual basic, c\'est lui qui fait lien OLE entre les formulaires
datasoft datasoft
247 contributions
Membre depuis le 26/01/2003
Envoyé le 19/05/2006 à 00:14


ce pb n\'apparait qu\'avec access2003.pour 2000 et 2002 pas de pb

Discussion trop ancienne

Cette discussion a été automatiquement fermée car elle n'a plus reçue de nouveau message depuis trop longtemps.

Nous vous suggérons de créer un nouveau message

« Retour sur la liste des messages de ce forum