Comment faire reconnaître ma carte son par Dapper?

gozillon gozillon
122 contributions
Membre depuis le 06/09/2001
Envoyé le 01/03/2007 à 21:17


Bonsoir,
je suis récemment passé de la version Breezy de Linux/ubuntu à la version Dapper, mais alors que l\'ancienne version reconnaissait sans véritable problème la carte son de mon Compacq Presario, avec Dapper, je n\'arrive pas à trouver les commandes qui me permettraient de la faire reconnaître. Cette carte, c\'est ATI Technologies Inc. IXP SB 400 AC\' 97. Il n\'y a donc aucun son de quelque nature que ce soit,pas même les bips ou les murmures du sytème.
Je tourne en vain dans les forums ubuntuesques et linuxiens...

Mylene Mylene
5 653 contributions
Membre depuis le 06/01/2003
Envoyé le 01/03/2007 à 23:20 Modifié par Modifié par MISS114 le 04/03/2


Bonsoir,

As-tu essayé de réinstaller le pilote Alsa ?

# sudo apt-get install alsa-base alsa-utils && alsaconf

Voir aussi ici : doc.ubuntu-fr.org/installation/son

Edit : je viens de vérifier ici : www.alsa-project.org/alsa-doc/index.php?vendor=vendor-ATI#matrix, le son devrait fonctionner avec Alsa.

Et là, surtout : minilien.com/?WQng9tAzix
gozillon gozillon
122 contributions
Membre depuis le 06/09/2001
Envoyé le 02/03/2007 à 09:48


Merci, Mylène, pour cette réponse :
j\'ai d\'abord passé la commande pour alsa-base, alsa-utils et alsaconf : les deux premiers sont bien installés mais la commande alsaconf n\'est pas reconnue. Je suis allé faire un tour sur la \"manpage\" d\'alsaconf mais ça ne m\'a pas éclairé.
A partir du premier lien indiqué par toi, j\'ai passé la commande modinfo soundcore et voilà ce qui m\'a été répondu :
@ubuntu:~$ modinfo soundcore
filename: /lib/modules/2.6.12-9-386/kernel/sound/soundcore.ko
description: Core sound module
author: Alan Cox
license: GPL
alias: char-major-14-*
vermagic: 2.6.12-9-386 386 gcc-3.4
depends:
srcversion: E11490DC3F523551C4C2A6D

Donc, apparemment, il ne devrait pas y avoir de problème. Or, il y en a un!

A noter que si je fais :
@ubuntu:~$ sudo alsactl store
Password:

j\'obtiens:

alsactl: save_state:1163: No soundcards found...

J\'ai beaucoup de mal à intéger dans ma réflexion les conseils en anglo-saxon et j\'avoue ne pas bien comprendre cette histoire de module (ou driver) intégré ou pas au kernel. J\'espère que cette difficulté va me permettre au moins d\'éclairer ma lanterne sur ce dernier point.
De façon peut-être simpliste, il me semble que si je trouvais 1°le bon pilote (ou module) pour ma carte son 2° le bon endroit où le placer dans l\'arborescence des fichiers système, ça marcherait. Non?


Mylene Mylene
5 653 contributions
Membre depuis le 06/01/2003
Envoyé le 02/03/2007 à 19:07


Que renvoit la commande : lspci | grep Audio ?
gozillon gozillon
122 contributions
Membre depuis le 06/09/2001
Envoyé le 02/03/2007 à 19:36





@ubuntu:~$ lspci | grep Audio
0000:00:14.5 Multimedia audio controller: ATI Technologies Inc IXP SB400 AC\'97 Audio Controller (rev 02)

cela ne me paraît pas anormal... ??

Mylene Mylene
5 653 contributions
Membre depuis le 06/01/2003
Envoyé le 03/03/2007 à 18:19 Modifié par Modifié par mylene. le 03/03/2


As-tu vérifié que tu fasses bien partie du groupe audio (Système > Administration > Utilisateurs et groupes)

modinfo soundcore


Prouve que le driver audio a bien été compilé dans le Kernel (donc pas besoin de l'installer).

La commande :

lspci | grep Audio


Prouve que ta carte est bien détectée, effectivement ce qui tendrait à faire croire que le module de son n'est pas chargé au démarrage.

Sur le net on ne trouve pas grand'chose, et en lisant la doc Ati du lien donné plus haut : si l'on suit les instructions, pour ce faire, il faudrait ajouter au fichier /etc/modules.conf, les lignes suivantes :

# ALSA portion
alias char-major-116 snd
alias snd-card-0 snd-atiixp
# module options should go here

# OSS/Free portion
alias char-major-14 soundcore
alias sound-slot-0 snd-card-0

# card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss



Sauf que ce fichier (modules.conf) existe bien sous Debian... mais aucune trace sous Ubuntu.... quizz... [°)]

As-tu essayé :

dpkg-reconfigure alsa-base


[S]PS[/S] : Didier vient nous aider... de toute façon, tu dors trop en ce moment... ... [:D]


gozillon gozillon
122 contributions
Membre depuis le 06/09/2001
Envoyé le 03/03/2007 à 20:18


@ubuntu:~$ dpkg-reconfigure alsa-base
/usr/sbin/dpkg-reconfigure doit être lancé par le superutilisateur
@ubuntu:~$ sudo dpkg-reconfigure alsa-base
Password:
@ubuntu:~$

Donc, apparemment, la recherche ne donne rien. Mais j\'ai essayé :
@ubuntu:~§ sudo gedit /etc/alsa/alsa-source.conf
Password:
- using device default
- using device default
ALSA lib pcm_hw.c:1305:(_snd_pcm_hw_open) Invalid value for card
ALSA lib pcm_dmix.c:819:(snd_pcm_dmix_open) unable to open slave

et en plus gedit a ouvert un fichier alsa-source.conf qui donne :

### ALSA source configuration file ###
# (This file is in GNU makefile format)

# List the card drivers to be built, separated by commas. For example,
# if you want to build the drivers for the Sound Blaster 16 and the
# Yamaha YMF cards then write:
# ALSA_CARDS=\"sb16, ymfpci\"
# The special name \"all\" results in all card drivers being built.
#
ifndef ALSA_CARDS
ALSA_CARDS=\"all\"
endif

# List the card driver options, separated by commas, all on one line.
# The special name \"all\" results in all possible options being set.
#
# This is an advanced feature. See ALSA\'s documentation for more info.
#
ifndef ALSA_CARD_OPTIONS
ALSA_CARD_OPTIONS=\"\"
endif

# Set to \"y\" if you want to build the modules without ISA PnP support.
# Otherwise, set to \"\".
#
ifndef ALSA_NOPNP
ALSA_NOPNP=\"\"
endif

# Set to \"y\" if you want to build the modules with debugging code.
# Otherwise, set to \"\".
#
ifndef ALSA_DEBUG
ALSA_DEBUG=\"\"
endif

J\'ai vérifié : je fais bien partie du groupe audiogroup.
A plus, malgré l\'impression d\'abuser... Merci

didier2000 didier2000
857 contributions
Membre depuis le 01/07/2002
Envoyé le 04/03/2007 à 02:17


bon alors dans l\'ordre que donne la commande \'lsmod\'
(liste des modules noyaux chargés)
normalement tu devrais trouver snd_atiix ou snd_ati_ix bref qqchose comme ça.

mais en lisant le thread, j\'ai l\'impression que tu as le module dans le noyau ET tu as essayé d\'installer alsa-driver. c\'est pas bon. c\'est l\'un ou l\'autre. peut-être que c\'est pas ça.

que donne la commande \'alsaconf\'.

et surtout (car ça m\'est arrivé), si c\'est une carte son (donc non intégrée à la carte mère), enlève la et replace la dans un autre emplacement. il se peut qu\'elle soit mal engagé ou nécessite un slot PCI plus rapide (le 1 ou le 4)

Didier vient nous aider... de toute façon, tu dors trop en ce moment...


Ben, Comment tu le sais?
kfreeflight.sf.net Main developer
A FlightGear GUI frontend designed for KDE users
Mylene Mylene
5 653 contributions
Membre depuis le 06/01/2003
Envoyé le 04/03/2007 à 09:19 Modifié par Modifié par mylene. le 04/03/2


A plus, malgré l'impression d'abuser... Merci


Mais non, tu n'abuses pas. Seulement que j'aimerais pouvoir être plus efficace que cela. Il m'est arrivé de résoudre un problème de son sous Debian, pour lequel je n'avais pourtant trouvé aucune réponse sur forum Debian. Donc j'essaye de t'aider au mieux, mais il est vrai qu'étant sous Linux depuis peu, je dois chercher plus que la moyenne, je suppose, tâtonner et faire des efforts pour comprendre comme je l'ai fait en mon temps pour Windows. Mais... aider les autres, en plus du plaisir que nous avons tous à le faire ici, que ce soit sous Linux ou sous Windows : aider nous enseigne toujours nous-mêmes. Alors... ! Pas de gêne ni d'un côté, ni de l'autre... [8D]

Donc :

Didier vient nous aider... de toute façon, tu dors trop en ce moment...


Etait une petite boutade amicale parce que Didier a visiblement plus d'expérience que moi sous linux, et j'ai pensé qu'il y avait peut-être une évidence qui me passait sous le nez. Donc en gros, j'espérais bien qu'il passe sur ce topic... [;)]

ET tu as essayé d'installer alsa-driver


Qui est installé sur mon Ubuntu.

La chose pas toujours facile, c'est que sous Debian, lorsque tu lances : # apt-get install alsa-base alsa-utils && alsaconf OU comme le dit Didier : # alsaconf, tu obtiens ceci à l'écran :













Sous Dapper... commande introuvable, or : alsa-base et alsa-utils sont bien installés sur ma dristrib Ubuntu !!!

Edit : effectivement, cette commande n'existe pas sous Ubuntu...
gozillon gozillon
122 contributions
Membre depuis le 06/09/2001
Envoyé le 04/03/2007 à 11:02


Salut à tous,
pour mylène : oui, c\'est un des caractères de Linux et du Monde Libre (soyons honnêtes, on le rencontre aussi autour des Mac et même parfois dans Windows) que ces forums où il est possible d\'exposer ses difficultés et d\'y recevoir des réponses qui transforment l\'agacement en plaisir d\'apprendre..
En lisant les captures d\'écran venues de Debian et en vérifiant sur mon Navigateur de fichiers, j\'ai vu qu\'un chemin existe /etc/modeprob.d/alsa-base et en ouvrant alsa-base avec gedit, j\'obtiens :
## autoloader aliases
install sound-slot-0 modprobe snd-card-0
install sound-slot-1 modprobe snd-card-1
install sound-slot-2 modprobe snd-card-2
install sound-slot-3 modprobe snd-card-3
install sound-slot-4 modprobe snd-card-4
install sound-slot-5 modprobe snd-card-5
install sound-slot-6 modprobe snd-card-6
install sound-slot-7 modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd modprobe --ignore-install snd $CMDLINE_OPTS && { modprobe -Qb snd-ioctl32 ; : ; }
install snd-pcm modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { modprobe -Qb snd-pcm-oss ; : ; }
install snd-mixer modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { modprobe -Qb snd-mixer-oss ; : ; }
install snd-seq modprobe --ignore-install snd-seq $CMDLINE_OPTS && { modprobe -Qba snd-seq-midi snd-seq-oss ; : ; }

# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { modprobe -Qb snd-emu10k1-synth ; }
install snd-via82xx modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { modprobe -Qb snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 modprobe --ignore-install saa7134 $CMDLINE_OPTS && { modprobe -Qb saa7134-alsa ; : ; }
# Prevent abnormal drivers from grabbing index 0
options snd-bt87x index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
#


C\'est trop énigmatiqe pour moi, pour l\'instant!

Pour Didier 2000, comment fais-tu pour dormir trop en envoyant des messages à 2 heures du matin?

La commande lsmod donne :

Module Size Used by
snd_mixer_oss 16128 0
snd 48644 1 snd_mixer_oss
rfcomm 34972 0
l2cap 22404 5 rfcomm
bluetooth 43012 4 rfcomm,l2cap
ppdev 9092 0
powernow_k8 11528 0
cpufreq_userspace 4444 1
cpufreq_stats 5124 0
freq_table 4484 2 powernow_k8,cpufreq_stats
cpufreq_powersave 1920 0
cpufreq_ondemand 5916 0
cpufreq_conservative 6820 0
video 16004 0
tc1100_wmi 6916 0
sony_acpi 5516 0
pcc_acpi 11392 0
hotkey 9508 0
dev_acpi 11396 0
i2c_acpi_ec 5760 0
i2c_core 19728 1 i2c_acpi_ec
button 6672 0
battery 9604 0
container 4608 0
ac 4996 0
rtc 11832 0
pcmcia 24584 0
yenta_socket 22540 0
i82365 23340 1
rsrc_nonstatic 12032 2 yenta_socket,i82365
pcmcia_core 44932 4 pcmcia,yenta_socket,i82365,rsrc_nonstatic
ipv6 217408 6
nls_cp437 5888 1
ntfs 92016 1
dm_mod 50364 1
md 40656 0
soundcore 9184 1 snd
sr_mod 15652 0
sbp2 21128 0
ieee1394 90936 1 sbp2
psmouse 26116 0
mousedev 10912 1
parport_pc 31812 1
lp 11460 0
parport 32072 3 ppdev,parport_pc,lp
ext3 115976 1
jbd 48536 1 ext3
thermal 13192 0
processor 23100 2 powernow_k8,thermal
fan 4740 0
usb_storage 64704 0
8139too 23552 0
8139cp 18432 0
mii 5248 2 8139too,8139cp
ehci_hcd 29448 0
ohci_hcd 18564 0
usbcore 104188 4 usb_storage,ehci_hcd,ohci_hcd
ide_cd 36996 0
cdrom 33952 2 sr_mod,ide_cd
ide_disk 16128 4
ide_generic 1664 0
atiixp 5648 1
ide_core 125268 5 usb_storage,ide_cd,ide_disk,ide_generic,atiixp
sata_sil 9476 0
libata 47876 1 sata_sil
scsi_mod 124872 4 sr_mod,sbp2,usb_storage,libata
unix 24624 455
vesafb 8088 0
capability 5000 0
commoncap 6784 1 capability
vga16fb 12232 1
vgastate 8320 1 vga16fb
softcursor 2432 2 vesafb,vga16fb
cfbimgblt 2944 2 vesafb,vga16fb
cfbfillrect 3840 2 vesafb,vga16fb
cfbcopyarea 4480 2 vesafb,vga16fb
fbcon 34176 72
tileblit 2560 1 fbcon
font 8448 1 fbcon
bitblit 5248 1 fbcon


et alsaconf donne

@ubuntu:~$ alsaconf
bash: alsaconf : commande introuvable
@ubuntu:~$ sudo alsaconf
Password:
sudo: alsaconf: command not found
@ubuntu:~$


Quant à la carte son, elle est intégrée dans la carte-mère.

Je piétine, je piétine, mais j\'ai quand même l\'impression d\'avancer !






didier2000 didier2000
857 contributions
Membre depuis le 01/07/2002
Envoyé le 04/03/2007 à 14:05 Modifié par Modifié par didier2000 le 04/0


c'est normal le module alsa i810 est celui par défaut quand on compile un noyau. pour avoir sa carte son dans alsaconf...... il faut recompiler ton noyau pour y inclure celui qui va bien.

et j'ai bien peur que notre ami gozillon va avoir besoin de recompiler son noyau ou d'installer alsa-driver, si la commande
'modprobe snd_atiixp'
ne marche pas.


kernel_config
kfreeflight.sf.net Main developer
A FlightGear GUI frontend designed for KDE users
gozillon gozillon
122 contributions
Membre depuis le 06/09/2001
Envoyé le 04/03/2007 à 17:20


hum! la commande en question donne des choses qui m\'inquiètent :

@ubuntu:~$ modprobe snd_atiixp
WARNING: Error inserting snd_page_alloc (/lib/modules/2.6.12-9-386/kernel/sound/core/snd-page-alloc.ko): Operation not permitted
WARNING: Error inserting snd_timer (/lib/modules/2.6.12-9-386/kernel/sound/core/snd-timer.ko): Operation not permitted
WARNING: Error inserting snd_page_alloc (/lib/modules/2.6.12-9-386/kernel/sound/core/snd-page-alloc.ko): Operation not permitted
WARNING: Error inserting snd_timer (/lib/modules/2.6.12-9-386/kernel/sound/core/snd-timer.ko): Operation not permitted
FATAL: Error inserting snd_pcm (/lib/modules/2.6.12-9-386/kernel/sound/core/snd-pcm.ko): Operation not permitted
WARNING: Error running install command for snd_pcm
WARNING: Error inserting snd_ac97_codec (/lib/modules/2.6.12-9-386/kernel/sound/pci/ac97/snd-ac97-codec.ko): Operation not permitted
FATAL: Error inserting snd_atiixp (/lib/modules/2.6.12-9-386/kernel/sound/pci/snd-atiixp.ko): Operation not permitted

En regardant un peu dans /lib/modules/2.6.12-9-386/kernel/sound/core je trouve quelques fichiers .ko que je n\'avais jamais rencontrés jusqu\'à présent Je vois aussi dans /modules/ qu\'il y a un embranchement : soit vers 2.6.12-9-386 soit 2.6.15-23-386. Qu\'est-ce que cela veut dire ?

Reste la recompilation du noyau. J\'en ai souvent entendu parler sur les forums, mais je ne sais pas ce que c\'est et encore moins comment procéder. Je veux bien tenter le coup (et même la tentative me tente) mais je ne comprends pas bien qu\'il puisse y avoir un problème de noyau avec une installation de Dapper toute neuve réalisée à partir d\'une réinstallation de Breezy.
Question subsidiaire (destinée à m\'éclairer mais surtout à vous éclairer sur les limites de ma familiarité avec l\'ordinateur) : qu\'est-ce que la sympathique image envoyée par Didier (on dirait une capture d\'écran sur un gestionnaire windows de périphériques)?


didier2000 didier2000
857 contributions
Membre depuis le 01/07/2002
Envoyé le 04/03/2007 à 18:10 Modifié par Modifié par didier2000 le 04/0


non il y a de l\'espoir:
cette commande doit être lancée en tant que root
sudo modprobe snd_atiixp

En regardant un peu dans /lib/modules/2.6.12-9-386/kernel/sound/core je trouve quelques fichiers .ko que je n\'avais jamais rencontrés jusqu\'à présent Je vois aussi dans /modules/ qu\'il y a un embranchement : soit vers 2.6.12-9-386 soit 2.6.15-23-386. Qu\'est-ce que cela veut dire ?


simplement que tu as (ou as eu) deux noyaux d\'installés
le 2.6.12... et le 2.6.15....
apparament tu es sur le 2.6.12

Reste la recompilation du noyau. J\'en ai souvent entendu parler sur les forums, mais je ne sais pas ce que c\'est et encore moins comment procéder. Je veux bien tenter le coup


c\'est vraiment en dernier ressort. on va essayé d\'éviter cela.

qu\'est-ce que la sympathique image envoyée par Didier (on dirait une capture d\'écran sur un gestionnaire windows de périphériques)


c\'est l\'application qui permet de configurer le noyau

Edit: donnes nous la marque et le modèle de ta carte mère

@mylène : la prochaine fois que qqun a un problème sous linux, envoie stp un message dans ma boite perso, car c\'est vraiment par hazard que je suis venu faire un tour sur mémo. bien sur si c\'est un message de qqun qui a vraiment un problème [;)]
kfreeflight.sf.net Main developer
A FlightGear GUI frontend designed for KDE users
Mylene Mylene
5 653 contributions
Membre depuis le 06/01/2003
Envoyé le 04/03/2007 à 19:20 Modifié par Modifié par mylene. le 04/03/2


la prochaine fois que qqun a un problème sous linux, envoie stp un message dans ma boite perso, car c\'est vraiment par hazard que je suis venu faire un tour sur mémo


OK, ça marche, merci... (+)

Reste la recompilation du noyau. J\'en ai souvent entendu parler sur les forums, mais je ne sais pas ce que c\'est et encore moins comment procéder. Je veux bien tenter le coup


c\'est vraiment en dernier ressort. on va essayé d\'éviter cela.


Ce qui m\'étonne, dans ta réponse, Didier, c\'est qu\'on peut lire dans ce lien :
www.alsa-project.org/alsa-doc/doc-php/template.php?company=ATI&card=ATI-IXP+southbridge+AC97+audio.&chip=IXP+SB150%2C+IXP+SB200%2C+IXP+SB250%2C+IXP+SB300%2C+IXP+SB400&module=atiixp

Ceci :

modinfo soundcore

If this command returns that you have this module, then you don\'t need to recompile your kernel



Or, la commande chez Gozillon, renvoit ceci :


@ubuntu:~$ modinfo soundcore
filename: /lib/modules/2.6.12-9-386/kernel/sound/soundcore.ko
description: Core sound module
author: Alan Cox
license: GPL
alias: char-major-14-*
vermagic: 2.6.12-9-386 386 gcc-3.4
depends:
srcversion: E11490DC3F523551C4C2A6D


Donc ce module est bien inclus dans le Kernel qu\'il n\'a donc pas besoin de recompiler (dis-moi si je me plante). Bref, comme dit plus haut, il est vraisemblable qu\'il ait ce qu\'il faut dans sa distrib (les drivers) mais qu\'il ne soient pas chargés au démarrage (tout faux ou pas ?)

Edit : Question à Gozillon : pourquoi bootes-tu sur un Kernel qui n\'est pas le dernier installé sur ta distrib ?

didier2000 didier2000
857 contributions
Membre depuis le 01/07/2002
Envoyé le 04/03/2007 à 19:44


c\'est exactement ce que j\'espère :
qu\'il y ait juste besoin de charger le module qui va bien. (d\'ailleurs je ne sais pas faire ça automatiquement au démarrage sous debian [;)] )
mais il se peut aussi que ce module ne puisse fonctionner (bug ou autre) et donc on passe par la recompilation du noyau et l\'installation de alsa-driver. (pour ne pas avoir les modules alsa du noyau et de alsa-drivers)
bon d\'accord les chances sont infimes. et c\'est pourquoi je lui est conseillé la recompilation en dernier recours.

(pour info sous gentoo il suffit de rajouter le nom du module dans le fichier /etc/modules.autoload.d/kernel-2.6)
kfreeflight.sf.net Main developer
A FlightGear GUI frontend designed for KDE users
gozillon gozillon
122 contributions
Membre depuis le 06/09/2001
Envoyé le 04/03/2007 à 21:07


D\'abord bonsoir à tous les deux,
ceci pour tenter de vous amadouer car je crains de vous avoir immobilisés pour une ânerie que j\'avais commise !
Je m\'explique : quand j\'ai eu installé Dapper, je me suis retrouvé avec un grub où chaque démarrage ubuntu était en double. Il faut dire que cette instalation s\'était faite à partir de Breezy (en remplaçant breezy par dapper dans le sources.list) mais qu\'à un moment il m\'a été demandé de placer le cederom que j\'avais d\'abord gravé avec une image iso de Dapper (vous me suivez?!)

Donc, suivant un conseil judicieux trouvé sur le forum de ubuntu-fr, j\'ai commenté sur /boot/grub/menu.lst les pavés correpondant aux lignes du grub qui me semblaient faire double emploi.
ET JE ME SUIS TROMPE ! J\'aurais dû commenter le 2.6.12 et j\'ai commenté (d\'ailleurs incomplètement) le 2.6.15

Vos dernières remarques (et peut-être la crainte de la compilation du kernel!) ont attiré mon attention sur ce point. Je viens de modifier mes #, correctement j\'espère. En tout cas, après le redémarrage, je retrouve le contrôleur de sons qui était inaccessible...

Une fois de plus, je vérifie que bien des difficultés de l\'ordinateur trouvent leur origine entre la chaise et le clavier. En tout cas merci.

Mylene Mylene
5 653 contributions
Membre depuis le 06/01/2003
Envoyé le 04/03/2007 à 23:29 Modifié par Modifié par mylene. le 04/03/2


... ... Tant mieux !

Si je t'ai posé la question du boot sur le Kernel... c'est que je me disais, qu'avec un peu ou beaucoup de chance... le dernier kernel serait optimisé pour ton driver. Bref, ça valait le coup d'essayer... [:o)]

d'ailleurs je ne sais pas faire ça automatiquement au démarrage sous debian


La difficulté, c'est que sous Debian : c'est dans le dossier /etc/modprobe.d
C'est exactement dans ce dossier donc, que j'ai ajouté le fameux fichier Nvidia pour le FastBandAdressing et le FastWrites (cf le post Nvidia de Bart... [;)] ), tout comme on retrouve aussi un fichier [S]sound[/S] qui pointe mon driver audio : ce fichier audio n'existe pas sous Ubuntu, difficulté contre laquelle je butais pour Gozillon... je cherchais ce fameux fichier qui pouvait appeler le driver, sans le trouver.

Edit : je confirme : un grand merci à Didier d'être passé...


Discussion trop ancienne

Cette discussion a été automatiquement fermée car elle n'a plus reçue de nouveau message depuis trop longtemps.

Nous vous suggérons de créer un nouveau message

« Retour sur la liste des messages de ce forum