Excel: combien d'années ds 7000 jours?

j-salim j-salim
116 contributions
Membre depuis le 07/09/2006
Envoyé le 02/08/2007 à 13:48


Salut,
comment resoudre le pb des années bissextiles pour arriver à determiner le nbre d\'années ds 7000 jours theoriquement et en utilisant Excel?
Merci
pidic pidic
3 572 contributions
Membre depuis le 20/04/2004
Envoyé le 02/08/2007 à 14:45


Bonjour,

Une fonction trouvée grâce à l\'ami Google : www.admexcel.com/trucdate.htm#form010
Encore ici : www.cathyastuce.com/excel/fonctionsexemples.php#biissextile
Pour les utiliser, je pense qu\'il faut renseigner un colonne contenant les années, et critérisées selon qu\'elles sont -ou non- bissextiles...

°°°°°°° Mon Blog Photos : ENCADREES.BLOGSPOT.COM/

Pegase Pegase
1 023 contributions
Membre depuis le 07/02/2002
Envoyé le 03/08/2007 à 00:14 Modifié par Modifié par Pegase le 03/08/20


Une fonction trouvée grâce à l\'ami Google : http://www.admexcel.com/trucdate.htm#form010
Encore ici : http://www.cathyastuce.com/excel/fonctionsexemples.php#biissextile

Dommage que les formules données sur ces sites soient fausses; Vérifiez avec 1700

En effet dans le calendrier grégorien une année est bissextile si elle est divisible par 4, sauf les années séculaires qui ne sont pas divisibles par 400 :
1600 et 2000 sont bissextiles.
1700, 1800, 1900, 2100, 2200 ne le sont pas.

La bonne formule est
=SI(MOD(A1;400)=0;\"bissextile\";(SI(MOD(A1;100)=0;\"normale\";(SI(MOD(A1;4)=0;\"bissextile\";\"normale\")))))
ou
=SI(SI(MOD(A1;400)=0;1;0)-SI(MOD(A1;100)=0;1;0)+SI(MOD(A1;4)=0;1;0)=1;\"bissextile\";\"normale\")
Voir le site perso.orange.fr/jean-paul.cornec/biss.htm

En faite les programmeurs informatiques ont inclus dans leurs programmes l\'instruction bissextile si divisible par 4 ont eu raison de le faire mais ce n\'est valable que de 1901 à 2099 !
Moi, le jour où j'aurai vraiment mon âge, je mourrai (Léo Ferré).
Pegase Pegase
1 023 contributions
Membre depuis le 07/02/2002
Envoyé le 03/08/2007 à 00:35 Modifié par Modifié par Pegase le 03/08/20


En vérifiant je viens de trouvé une condition que je ne connaissais pas : Une année n\'est pas bissextile si son millésime est divisible par 4000
Donc à vérifier pour les optimistes : 4000, 8000, 12000 ne seront pas bissextiles

La bonne formule est donc (retenez votre souffle)
=SI(MOD(A1;4000)=0;\"normale\";(SI(MOD(A1;400)=0;\"bissextile\";(SI(MOD(A1;100)=0;\"normale\";(SI(MOD(A1;4)=0;\"bissextile\";\"normale\")))))))

Et un excellant lien qui explique le pourquoi du comment de ces conditions complexes
www.afapl.asso.fr/nv32_3.htm
Moi, le jour où j'aurai vraiment mon âge, je mourrai (Léo Ferré).

Discussion trop ancienne

Cette discussion a été automatiquement fermée car elle n'a plus reçue de nouveau message depuis trop longtemps.

Nous vous suggérons de créer un nouveau message

« Retour sur la liste des messages de ce forum